OS instalation woes

Jan 18, 2020 - 2:46 PM

  • Hello all,

    I had the seemingly common issue with HDMI audio when I powered on my Atomic pi for the first time, and the general consensus I read was to change to an updated OS of your preference. I first tried Lubuntu 19.10, and that worked for a hot second, though quite slow. I ran through the usual updates and restarted the machine, but found it would get stuck rebooting. Tried chaining some boot settings, now the screen resolution is the wrong size, desktop background went black, and updates throw path errors.

    I've tried Debian Buster, but the disk image tool didn't recognize a non-ubuntu ISO
    Tried Mint 19.3, but it would not recognize the internal memory as a disk.
    Reinstalling Lubuntu has the same result as in the last paragraph.

    Hopefully I'm just doing something silly, but I'm at a loss for what might be causing these problems.

    0
  • I got some of the display issues worked out, I got lubuntu reinstalled 'properly' after being sure to check 'format disk' for sure to clear old contents.

    Still a lot of problems with the atomic pi and Lubuntu 19.10

    But, I've gutted an 8yr old laptop at this point to run my TV.
    I'll use the screen, soundbar, webcam, and WiFi antennas from the former laptop with the atomic pi once I get the stability issues worked out. I'm hearing suggestions to run Lubuntu 20.04 for some of the stability issues I'm hitting including crashes, audio problems, and inability to shut down.

    0
  • Buster running smoothly here

    0
  • Hello There! Some Good News! (partly copied from the other pulseaudio not working thread and extended)

    Sorry that I drop quite late on this HDMI sound issue. I received my first Api very recently.

    The Atomic Pi that I received on January 2020 was shipped with a 18.04.1 Bionic Lubuntu.
    So you may receive an SBC with this LTS version. In this LTS version, pulseaudio, the sound server does not work so well with the HDMI sound card, and all the sound delivery may be very unstable.

    Then what you read here is probably relevant.

    A proven solution: You should as soon as possible download from dlidirect
    and install the fresher 19.04 Disco Lubuntu image on your SBC.
    This is because the pulseaudio version which is embedded on the Disco is
    pulseaudio version 12.2
    With this newer version of pulseaudio, every thing works fine.
    This is what I can confirm from my installation, and my tests.

    I did not try the 18.10 Cosmic version.
    I did not try the newer 19.10 Eoan, because we have no APi dedicated system image available from the dlisite.

    And to upgrade the LTS Bionic from 18.04.1 to the last LTS subversion18.04.4 does not solve the problem,
    because even the last 18.04.4 has yet the buggy pulseaudio version 11.1.

    The next LTS version to come , called Focal, is to be delivered as 20.04,
    in two months from now.
    It is announced with a pulseaudio version 13.xxx, that should be more than okey.
    Though, I have no idea whether and when we will get an APi dedicated Lubuntu Focal image ready to be downloaded and then dumped on the eMMC.

    And at this moment , I dont know how to build such APi dedicated system image with all the specific APi drivers and configs. Do You? May you explain?

    Hello Thierry, from your recent message, I read that you have a fine running APi working on Debian Buster . Congratulations!
    The Pulseaudio version of Debian Buster was made quite fresh during the updates.
    It avoids the problems encountered with the Ubuntut LTS 18.04 even in the latest subversion 18.04.4
    Is your Debian system on the USB key, on the SD card, on dumped on the eMMC?

    Thierry, did you manage to install the Api specific drivers?

    I am very concerned about using the Xmos sound together with the onboard class D amplifier? I would apreciate your feed back

    Have fun , and more with your wonderful APi!
    Best Regards

    0