Where can we download the AI developers kit image?

Dec 8, 2020 - 4:03 PM

  • I've got the Atomic Pi development kit from Amazon with the large breakout board. I also have an Intel Movidius NCS2 left over from a Raspberry Pi4 project.

    We can we get the downloadable image as promised on the Kickstarter page?

  • As far as I know, they never completed that part. Keep in mind the Kickstarter page is somewhat misleading; they never designed and built the Atomic Pi, they were raising funds so they could buy the surplus computer boards. I really can't figure out how to use their regular OS images anyways because they're in .zip files instead of the usual .iso format.

  • I've had little luck with the pre-installed image or the ones I've downloaded. But standard Ubuntu-Mate 16.04 and 20.04 has worked well for me. I was curious if they had better luck with OpenVINO and its GPU module.

    Back when OpenVINO was installed with a tar.gz file, with the help of people on the Intel forums I managed to get the GPU example to run on my Atomic Pi. Unfortunately what I did to get the OpenCL drivers to install broke the OpenCV that came with OpenVINO.

    In any event the Atomic Pi is a nice Atom 8350 system. Similar on Amazon is ~$140 https://www.amazon.com/Fanless-Desktop-Computer-Windows-Mounting/dp/B07QY8LDGX/ref=psdc_13896591011_t4_B07R6RWPM7

    For about 3X the Atomic Pi cost you get a case and 2 USB2 ports instead of 1, 128GB SSD drive instead of 16GB eEMC and 4GB ram instead of 2GB. Worthwhile but generally wasted for IOT type usage.

  • If anyone from Digital-Loggers is out there, I just got a spare AtomicPi Developers Kit from Amazon and decided to try the pre-installed Lubuntu 18.04 image. The pre-installed Lubuntu image is poorly configured, and I think Lubuntu is lame, so until now simply booted a Ubuntu-Mate USB installer and wiped the pre-installed image instead of messing with it.

    Since this was to be a spare system (I've two running my AI system 24/7) I decided to see what I could do with it, since it successfully ran two of the three camera/sample scripts (gstreamer.sh doesn't work).

    With much frustration, I turned it into a useful system for playing with AI. Specifically it boots to the desktop without asking for login or password, screen blanking is disabled, has Coral TPU support installed, and OpenVINO 2020.1 installed, along with the other bits and pieces needed to run my AI code (samba server, mosquitto, node-red, etc) https://github.com/wb666greene/AI-Person-Detector

    Approx 54% of the eEMC is used, according to the df utility.

    My AI system uses an ext4 formatted SD card in the on-board reader to store the detection images, automatically deleting ones older than X days. Images can be viewed remotely and downloaded via samba. A Coral TPU or NCS/NCS2 is in the USB3 port and the system normally runs headless without keyboard, monitor or mouse connected using a wired connection (multiple camera rtsp streams eat up WiFi bandwith). I still need to verify that Lubuntu boots fine without KVM attached as my Ubuntu-Mate systems do. Edit: tested it, started my AI without monitor, keyboard and mouse attached all working as expected except no sound output.

    I tried installing OpenVINO 2020.3, which is the last version that supports the original NCS, newer versions only support the NCS2, but the installation is broken and doesn't compile the OpenVINO test/verification code, so I uninstalled it and installed 2020.1, which I had used for recent upgrades to my AI system.

    Running the compiled security barrier demo/verification program I get ~3.6 fps reported with the CPU plugin
    Using the MYRIAD plugin with NCS ~13 fps, with NCS2 ~22 fps.

    ssh -X works to run the barrier demo, I got 4.5 fps using the CPU plugin.

    If you can supply code or instructions to use the developers kit camera with OpenCV and other normal webcam apps, I believe this image could be made downloadable as your AI developers kit image Although I think Ubuntu-Mate would be a better overall choice if the camera could be made to work with it.

    Edit: Another issue that needs to be addressed is sound. Can't get sound to work. My opinion of the Digital-Loggers supplied images remains very low. I briefly tried: atomicpi_ubuntu_bionic_lxde_standalone_1.0.0.153.zip and replaced it with a normal Ubuntu-Mate16.04 image, audio doesn't work either, but it sends MQTT messages for audio alerts to another system running espeak-ng for audio notifications, so I didn't need audio for this application.

    On my third Atomic Pi I did a normal installation of Ubuntu-Mate 20.04 and sound over hdmi works using what appears to be the default Intel drivers for Atom. None of the Condor stuff shows up.

    One serious issue on the Atomic Pi and possibly other similar systems with Atom processors is that it locks up when shutting down or restarting. A killer for IOT type usage. This is also true for the DLI 20.04 focal_lxqt zip image.

    I found a fix, its seems the mei module is causing the lockups at shutdown/reboot. I edited /etc/modprobe.d/blacklist.conf and added:

    blacklist mei
    blacklist mei_txe
    blacklist mei_hdcp

    This cures the hang on shutdown/restart and I've not noticed anything that doesn't work since the change.

    This post was edited Dec 22, 2020 01:10PM
  • JT Alexander (@jtalexander):
    I really can't figure out how to use their regular OS images anyways because they're in .zip files instead of the usual .iso format.

    I plug in a USB3 hub, burn a Ubuntu (I like MATE) installer to a USB stick, unzip the downloaded image archive to create the *.img file and copy it to another USB stick or the writable part of the Ubuntu installer if your USB stick is big enough.

    I then boot the Ubuntu installer in try without installing mode, and overwrite the eEMC with the unzipped image using the dd utility (open a terminal window and do sudo -i and run the dd command).

    But IMHO you are better off just letting the Ubuntu installer install to the eEMC unless you need the camera and/or GPIO and other extra hardware.

    I can't get the camera to do anything but run 2 of the 3 samples/camera scripts and the GPIO and other extras aren't useful to me, YMMV.

    This post was edited Dec 15, 2020 02:06PM