Got a "Sour" Pi...

Feb 7, 2019 - 8:54 PM

  • Just received my APi, and have some strange issues...
    FYI, I am powering it up with a regulated +5V bench supply (with plenty of current margin). ;)

    The first thing I did was to go into the BIOS and set the current time & date, and disabled fast start (to see the POST messages).

    The First error I get is File '/boot/' not found
    Next, it says Can't find command 'hwmatch'
    Then, it boots into the GRUB menu, and I Lose all Keyboard support... arrow keys/enter key not functional, 2 Mouse pointers (one fixed in the center of the screen, and one that moves with the mouse, but the mouse buttons aren't functional).

    Now the WEIRD part...

    After a minute or so, the highlight MOVES ITSELF back and forth between the options (no keypresses made by me), and eventually goes into 'Generic' boot option, Reboots, and eventually I get to the GUI, where the Keyboard & Mouse are fully functional again.

    I figure that maybe the GRUB Bootloader itself is damaged, so I log into the GUI using the Default password (W56mDaJy7w in my case), and I try to do a Software Update.

    ~ The Software updater finds new updates, and when I select to continue with the update, it asks for the ROOT password... Leaving it blank fails with incorrect password, and so does entering the above Default password. ~

    (EDIT): I was able to get into the console and reset the Root password.
    Software Update was successful... No more GRUB issue (I think)..

    The POST errors still continue, though... What's up with that?

    -J

    This post was edited 2019-02-08 13:17:40 -0500
    0
  • I believe the File '/boot/' not found and the Can't find command 'hwmatch' are normal. By normal I mean all of ours issue those errors. I have two 'full enchiladas' and both do that. I posted a question about it on the AtomicPi sub-reddit as well and at least one other person said they got those as well. Both of mine had oddball issues from the start and, for whatever reason, it turned out to be filesystem corruption. This was from first boot out of the box. I had to boot from an lubuntu install USB flash drive in order to run fsck on the root filesystem on the eMMC, but after that they are both running perfectly.

    Your issues with the mouse/keyboard/things moving by themselves are weird indeed and I can't say I saw anything like that, thankfully. It sounds like yours is straightened out now, but it may be worthwhile to create a bootable USB flash drive using the lubuntu install ISO (I was able to use an old 1GB 'freebie' flash drive I had on-hand for this) and boot from that and run a full check on your eMMC partitions just to be sure there's nothing going on there.

    Maybe someone from Digital Loggers can chime-in on the /boot/ and 'hwmatch' errors we are seeing, but it seems to me that this is something with the BIOS looking for a boot partition on non-existent media. As if there is a 'hidden default' boot device in the BIOS that it looks for before moving on the the boot order that we have the ability to modify in the BIOS. I don't think this is related to the IPv4 or IPv6 PXE boot options either as I've disabled those explicitly on mine and still see those errors immediately after POST.

    This post was edited 2019-02-07 22:47:35 -0500
    1
  • Thanks for the reply... Now I know that I'm not the only one seeing these POST errors.

    I'm thinking that the weird cursor movement may possibly have been due to a flaky El-cheapo USB Keyboard... I have since replaced it with a Logitech K400r Wireless keyboard, and haven't seen anymore weird behavior (I still haven't had a need to re-invoke GRUB, though)…

    I'm also thinking about just blowing the current Lubuntu install away, and installing the latest version of Mint 19.1 Tessa. ;)

    Update #1:
    Tried installing Linux Mint 19.1 via Live DVD (I have a USB 3.0 DVD drive)… The BIOS sees the drive, but will NOT give the option to BOOT from it. :/

    (FEATURE REQUEST: Modify the BIOS to allow selecting Bootable USB devices.)

    Had to use Etcher to write the image to a MicroSD card and was able to boot from that.

    Next, tried installing Mint using Non-UEFI (Legacy Bios) installation... Install completed, but the Pi will not boot (keeps returning to the BIOS Setup screen) :(

    Reinstalled again from Scratch using UEFI instead... Success.
    POST is now free of errors.

    This post was edited 2019-02-08 11:49:36 -0500
    0
  • Same Issues as stated here as well. I ditched the lubutu and loaded xubutu without any problems. FYI, One thing I notice before the reload is that the root partition for lubuntu was not expanded so there was about 7GB unallocated. I was able to use gparted and expand the partition without a problem. I think the original lubuntu load had some problems that went unnoticed before shipment.

    This post was edited 2019-02-08 17:34:33 -0500
    2
  • My Pi seems pretty flaky. I'm seeing the grub menu selection moving around and selecting things at random.Also reboots while trying to boot and general erratic behavior. All without a keyboard or any other USB peripherals attached. Here's a vid:
    https://www.youtube.com/watch?v=mr_hNGEytQk

    I'm using a 6A Aliexpress PSU and it shows a solid 5.1v while the Pi is running. I guess it's possible that the PSU is delivering dirty power or that the 6A rating is BS but I have also tried with a 2A wall wart and getting the same result. With a keyboard attached I can go into BIOS menu and navigate around, no issues at all.

    Cheers,
    Rhys

    0
  • Okey so a bit more info. I tried it without the breakout board (large) and the gurb menu no longer appears at all (unless I attach a KB and press escape during boot) and I realize now that it shouldn't appear under normal circumstances and it's only because of the key mashing effect while the breakout board is a attached that it appears. It still didn't boot but I suspect that's because the image is now koozered from hard resetting so many times while it was trying to boot with the breakout board attached.

    As soon as I reattached the breakout board the grub menu starts appearing again and going haywire.

    So it looks like either my Pi or breakout board is flaky. Or it may still be a PSU issue I guess? It's a bit of pain because I'm new Zealand and got it freight forwarded to me. My risk I guess. :)

    0
  • From looking at the video it seems that behaviour could possibly be caused by a bad power supply. Especially the random restarts where it goes back to the BIOS splash. Of course the board could be bad too, but don't give up yet. I had two of them that did strange things when first turned on (don't recall that odd GRUB menu activity though), and would not boot. It was due to some unexplained filesystem corruption. I had mine running off of a bench/lab power supply where I could guarantee correct voltage and current and monitor the current draw as well so it wasn't a power issue. I dowloaded the Lubuntu 18.04 installer:

    http://cdimage.ubuntu.com/lubuntu/releases/18.04/release/lubuntu-18.04-desktop-amd64.iso

    note: there's probably a new release by now...

    and created a bootable USB flash drive from that. I then booted from that and repaired the install that is on the eMMC (had to run fsck twice to fix it all). It then worked fine after that so that's at least worth a shot. If you have a DMM that you can place in series with your power supply while booting the Atomicpi and monitor the current draw that would be good to do as well. If you can source another PS with at least a 3A rating to test with that would be good too.

    Hopefully it's just a PS issue and the board is OK.

    This post was edited 2019-02-25 07:57:09 -0500
    0
  • You might want to try adding some extra filtering/noise decoupling of the +5V rail on the Enchilada (Large breakout) board, and see if that makes any difference.

    I added a 22uF low-ESR Electrolytic and a 0.1uF Ceramic cap to the VCC +5V and Ground buss right next to the 26 pin board connector in the Prototype area. (Just to appease my OCD.) ;)
    It may (or may not) help, but it certainly won't harm anything.

    This post was edited 2019-02-25 21:10:25 -0500
    0
  • Thanks everyone for the input. I think I've got to call it. I tested with an ATX PSU (don't why I didn't think to do that earlier) and getting the same result so I think I can pretty rule out PSU being an issue. I could try and do a reload of the O/S but the fact that the erratic behaviour happens at the grub menu (which is pretty low level) and only when the breakout board is attached I think it can only be a hardware fault of some kind. Agreed?

    Cheers,
    Rhys

    0
  • Starting to sound that way Rhy. Out of curiosity, you could try disconnecting all of the cables that connect the breakout board to the processor board so that the only connection between the two is the 26 pin connector on the bottom and see if it still does it. If that seems to resolve it then power it off and connect one back at a time and test again. The odd grub menu behaviour sort of seems like some erroneous signals may be getting to the processor board's uart via CN10. Just a wild guess though.

    0
  • Hi...in my case this was from first boot out of the box. I had to boot from an lubuntu install USB flash drive in order to run fsck on the root filesystem on the eMMC, but after that they are both running perfectly.

    https://www.7pcb.ca/

    This post was edited 2019-08-07 16:17:11 -0400
    0
  • The large breakout board (enchilada), has a USB-TTL converter tied to a cable that goes to the debug SIO header marked UART. If the input is left floating (JP1,2), it can pick up noise that looks like a ghost typing on the keyboard.

    0