HDMI Audio not working on Lubuntu reinstall

Feb 12, 2019 - 1:34 PM

  • I can't get HDMI audio to work and have a fresh install of Lubuntu.

    pacmd list-sources shows:

    • index: 8 name: <alsa_output.pci-0000_00_02.0-platform-hdmi-lpe-audio.stereo-fallback.monitor> driver: <module-alsa-card.c> flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY state: RUNNING suspend cause: priority: 1030 volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB balance 0.00 base volume: 65536 / 100% / 0.00 dB volume steps: 65537 muted: no current latency: 52.55 ms max rewind: 344 KiB sample spec: s16le 2ch 44100Hz channel map: front-left,front-right Stereo used by: 1 linked by: 1 configured latency: 40.00 ms; range is 0.50 .. 2000.18 ms monitor_of: 7 card: 0 <alsa_card.pci-0000_00_02.0-platform-hdmi-lpe-audio> module: 7 properties: device.description = Monitor of Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers Stereo device.class = monitor alsa.card = 0 alsa.card_name = Intel HDMI/DP LPE Audio alsa.long_card_name = Intel HDMI/DP LPE Audio alsa.driver_name = snd_hdmi_lpe_audio device.bus_path = pci-0000:00:02.0-platform-hdmi-lpe-audio sysfs.path = /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0 device.bus = pci device.vendor.id = 8086 device.vendor.name = Intel Corporation device.product.id = 22b0 device.product.name = Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers device.string = 0 module-udev-detect.discovered = 1 device.icon_name = audio-card-pci

    and pulseaudio is showing the Atom/Celeron/Pentium Processor, but there is 0 sound. Hooking a headset up works just fine. Any ideas?

  • check out this repy on Reddit: https://www.reddit.com/r/Atomic_Pi/comments/ao7am1/check_out_our_wiki/

    Has some notes on sound problems

  • Excellent! And good find. I will try this tomorrow.

    Someone also replied back that 18.10 works. My next step was to install the ASLA nightly drivers but havent gotten around to testing yet:

    sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily.
    apt update.
    apt install oem-audio-hda-daily-dkms.
    Reboot the system.

    Will report back what works!

  • latest version worked for me.. main page 64 bit 18.10

  • Fixed!

    Followed the reddit post that mentioned:
    "speaker-test -D hw:0,X -c 2 -r 48000 (where X was 0, 1 or 2) and found that speaker-test -D hw:0,2 -c 2 -r 48000 produced output on my setup. I then added the following lines to the end of /etc/pulse/default.pa

    load-module module-alsa-sink device=hw:0,2
    set-default-sink output 0"

    It also sounds like Ubuntu 18.10 works as well. However I am remaining on the LTS version if possible.

  • I’m trying this, Wesley. New to Linux/Unix/Ubuntu, but shouldn’t there be a # in front of set-default-sink?

  • Mine is still not working. Now I am doing this:


    but at the end of that purge, I get the following:

    Configuration file '/etc/pulse/default.pa'
    ==> Modified (by you or by a script) since installation.
    ==> Package distributor has shipped an updated version.
    What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
    D : show the differences between the versions
    Z : start a shell to examine the situation
    The default action is to keep your current version.
    *** default.pa (Y/I/N/O/D/Z) [default=N] ? y
    Installing new version of config file /etc/pulse/default.pa ...
    Installing new version of config file /etc/pulse/system.pa ...
    Setting up pulseaudio-module-bluetooth (1:12.2-0ubuntu5) ...
    Processing triggers for libc-bin (2.28-0ubuntu1) ...
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  • Another error I get while purging PulseAudio:

    installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 1
    Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
    Processing triggers for dbus (1.12.2-1ubuntu1) ...
    Errors were encountered while processing:

  • To answer your question about the # in front of: set-default-sink output 0

    No, the # indicates that the line is a comment so you must remove the # in order for the directive to be read by pulse audio and take effect.

  • I saw somewhere else where it was written with on #. Maybe because it was a template or a samle. In the .conf file, every single line on my device has ; in front of it. What's the point of a config file, if it's all commented out?

    I did make the sound work yet. There was at some stage where I could open the volume control window without any error messages. But nothing changed there made the sound work. And now, since troubleshooting various things, it opens with one of two error message windows (one is the one about trying to reconnect in 5s, the other one just says it can't connect).

    Will updating to 18.10 make any difference? I tried updating (and setting it to non-LTS first), but id never updated to anything beyond 18.04.02 (I think that is what I have)

    Sorry for these questions, I am a bit new with this (but learning a lot, thank you!)

  • My suggestion would be to do a fresh install of Lubuntu 18.04 or 18.10 to an SD card from a bootable USB flash drive. Unless, you don't really care about what is on the eMMC flash then you could skip the SD card and just install directly to eMMC.

    You could also use one of the newer vendor-provided images from here:


    Just a note that the images on the link above are not 'installer' images, but images you would need to download and directly transfer to eMMC via dd or other utility.

  • Fresh install of 18.10 also worked for me, had to downgrade from 20. Tried the config edit but didn’t work