USB Instability with multiple devices on a non-powered hub?

Feb 14, 2019 - 7:02 PM

  • So far so good with the AtomicPi with OpenCV up and running and working well. However, I noticed that sometimes the board will freeze or reset if I have too many devices on the attached USB Hub. I have a non-powered 4 port Hub connected that has a Keyboard, Mouse, and Logitech Web Cam connected. If I also connect a USB Stick, within a few minutes, the screen freezes and I have to power cycle. The stick mounts fine and the files are accessible for the few minutes before the freeze though. I have tried different USB sticks from different manufacturers with the same results. If I unplug the web cam first though, there is no problem.

    The problem is even more pronounced if I connect a second web cam instead of the USB Stick. In that case the board will freeze almost immediately or reset. When it comes back up, both web cams seem to work fine, but then a few minutes later, the screen will freeze again. I have been able to run this same setup with the exact same hub on a Raspberry Pi 3 B+ without issue. I cant imagine that the devices connected are exceeding the half Amp constant draw limit of the USB port, though that is my current thought. Is there some tight control on current draw on the USB port on the AtomicPi that isn't allowing for the in-rush of the added devices (Or is the Raspberry Pi loose on tolerance for current draw on a USBPort?)? I will be trying again tonight with the hub externally powered and I suspect that I will not see the same problems.

    Just wanted to document this to assist others who may encounter the same issue.

  • I tested last night by creating an adapter to make the same hub into a powered hub. I attached this to a power supply that could provide more than sufficient current to power everything connected. This seemed to make the problem go away. I didn't get a chance to put a meter on it to see what kind of current it is actually drawing. I will try to do that tonight.

  • Just a guess, but this looks power-related.
    More USB stuff is more load on the P/S
    Thanks for the support
    -Martin & Team

  • The power supply connected is a 5V 8 Amp supply. If I power the USB Hub off the same supply as well, the problems do not occur so its not the supply. I have also tested with a 6 Amp Bench supply and encountered the same issues. Note though that on issuing an lsusb command, I do notice that there are several internal devices on the same bus with the external connector. It may be that the combination of those devices and my devices are exceeding the max power for the port and causing the shutdown to protect the port (A good thing).

    I don't really see this as a big deal though. Using a powered hub or power adapter between the Hub and board guarantees that the devices connected will have the necessary power as well as helps to protect the USB port from damage.

  • I am only using a 2.5a power supply and a powered USB hub with what I thought would be too many devices for it to handle(portable SSD, mouse, keyboard and PS4 controller) and haven't had an issue yet. Have you tried a fresh installation of an Ubuntu 18.10 variant? That seemed to clear up some weird issues I was having and now everything has been running splendidly.

    This post was edited Feb 21, 2019 03:23AM