BIOS not retaining settings

Feb 17, 2019 - 11:19 AM

  • I've got an issue where changes to BIOS settings are not saved. No power interruption occurs, simply change BIOS settings (disable quiet boot, etc.), save/exit, then re-enter BIOS and the settings are back to the original values. A common cause for this appears to be a non-functional CMOS battery, but as no power interruption occurs, this seems unlikely to be the cause in this instance.

    0
  • Same problem here. Kind of annoying since the default boot order is PXE IPV4 then PXE IPV6 and the timeout takes forever unless you bypass with the keyboard. I keep changing the boot order, it keeps changing back.

    This post was edited 2019-02-17 18:09:41 -0500
    0
  • Guys-
    Haven't run into this yet, but I'll pass it on and we'll look for it. NB: the RTC Reset does clear CMOS BIOS setup.
    Thanks for the support!
    -Martin

    0
  • Just got my pi and have the same problem with bios setting not being saved. I changed the boot order, save & exit, then enter bios only to see it was reset to its original state. Was this solved? Or what am I doing wrong?

    0
  • could you unplug the cmos battery and see if it still happens?

    0
  • Have the same issue. I removed the cmos battery, and without powering off (only pressing the reboot button) the following happened:

    • first reset: values were kept as I changed them (hey, great, it seems to work!)
    • second reset: values were lost again (ok, it still doesn't work :-( )

    In another try, it worked several times after reset, but not any more after a reset after the OS (I tried Windows for curiosity) had started to boot.

    But what were you up to by removing the cmos battery? If it worked then, would the easy proposal be to exchange it?

    This post was edited 2019-06-23 14:40:07 -0400
    0
  • Greg, I wouldn't trust the CMOS battery. I replaced mine and it solved the BIOS retention problem.

    0