No response upon applying power for first time

Feb 18, 2019 - 3:55 PM

  • I have received my Atomic Pi, but upon connecting

    • Display via HDMI cable
    • a Keyboard via USB port
    • 5V regulated power supply via pins 3,5 (GND via pins 2,4) nothing happens. Nothing comes up on the screen. I've double checked that the monitor is working and that the HDMI cable is good. Should there be an LED on the Atomic Pi that lights up if it is receiving power correctly?
  • Hi Sir-
    There's no power LED on the CPU, but there is on the breakout. Suggest double-checking the power by probing from the top of the connector. APi will draw a peak of around 2A with no peripherals. It also takes a bit longer to boot after a CMOS reset, so wait it out for 30s or so and you should see the login on HDMI. Call 408 330-5599 if we can help.

  • We didn't get the breakout. Have probed at the regulated power supply and at the pins where connected to Atom Pi. Power is reaching the board. Power supply says that it is only seeing .1Amp draw. I have given it over a minute several times. I've also tried other pins (5,7 for power and 4,6 for GND). Still no response. Maybe I'll have to give you a call tomorrow.

  • Mine works fine on an old monitor I have with an HDMI to DVI adapter but upon testing it out on my TV tonight I don't get any picture. Can see it on my network so I know it's running fine.

  • Martin was kind enough to encourage me to continue pursuing a proper power supply. I ended up using a different 5V regulator and now the Atomic Pi is powering up!