Root password is absolutely required

Feb 21, 2019 - 4:32 PM

  • I have seen a few places that claim there is no password for Root. However, to change the time, update software, and any number of other things, the password for root is requested. I have tried changing the password in the bios and in the users and groups section with no luck. Please tell me there is something I am missing.

    0
  • It's not unusual for there not to be a root login and password depending on the version of Linux your using. When there is no root login, use the sudo command in front of the command your going to use. The password it will ask you for is your user password. This is allowed because you are part of the sudo group which has that privilege. e.g. sudo apt-get update

    0
  • I'm not even using Terminal though. I'm talking about changing the timezone in Lubuntu or updating the software using the Software Updater application listed in the start menu. Every time I try, it gives me a prompt for the password for root with no option to choose the default user. As such, the default password does not work.

    0
  • Hi Pete. What you are seeing is the default PolicyKit (polkit) authorization implementation that is part of the default Lubuntu install on the AtomicPi. To add the atomicpi user or any other user you have created on the system and replace root as the 'default' password prompt for authorization you can edit the file (need to use sudo, a root shell or otherwise ensure the text editor you are using has root privileges):

    /etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf

    and add the user you want at the end of the last line of the file such as:

    [Configuration]
    AdminIdentities=unix-group:sudo;unix-group:admin;unix-user:atomicpi

    save the file and then when you launch the app in question next time such as time-admin, users-admin, update-manager, etc... via the graphical interface you'll be prompted for that user's password instead of root.

    Other options (not necessarily recommended) are to set a root password and use that or uninstall polkit altogether.

    This post was edited 2019-02-23 10:46:39 -0500
    2
  • I ended up just setting a root password to get around this problem. If you look in the /etc/shadow file you will see that there isn't a password set for root, yet just hitting enter at the prompt won't work. I simply ran the sudo passwd root command in terminal and it let me change it from the atomicpi user.

    0
  • Yes. That is default for Lubuntu/Ubuntu/Debian for root to not have a password and, thus, be disabled. It will become active if you set a password for it as you did. There are security implications in having root active, but no technical issues with it as long as you are aware of what those implications are.

    0
  • Thanks for the advice, Radu7! I did that and can now change things. I still can't change the password for the atomicpi user, however. Every time I try it just shows me the spinner pointer forever after entering the new password twice. It never throws an error message or anything. It just spins endlessly.

    0
  • No problem Pete. The issue with the atomicpi user passwd you are seeing is odd though. I saw a few quirks on mine prior to re-installing the OS such as the login coming up, entering the passwd for the atomicpi user and the system 'acting' like you were going to be logged-in only for it to just go right back to the login prompt (no errors about a bad passwd, etc...). It did that every single time.

    You could try launching a root shell and then changing the passwd for the atomicpi user if you're feeling adventurous. From an lxterm terminal:

    sudo bash - (sudo -s will work as well, but is not exactly the same)

    then from the # prompt: passwd atomicpi

    Perhaps that may work and successfully change the passwd for the atomicpi user for you.

    0
  • root is not required to change the timezone. This command will work in a terminal window.

    sudo dpkg-reconfigure tzdata

    0
  • ...saw a few quirks on mine prior to re-installing the OS such as the login coming up, entering the passwd for the atomicpi user and the system 'acting' like you were going to be logged-in only for it to just go right back to the login prompt

    radu7, I noticed this happen on my default Lubuntu installation as well but only after multiple successful logins and figured I just screwed something up myself. I had other troubles with the Lubuntu image such as random freezing I assumed was from overloading my USB hub but upon wiping the emmc I haven't had a single issue since.

    0