PulseAudio Not Working

Feb 22, 2019 - 12:24 PM

  • The sound icon is greyed out and when selecting sound settings, PulseAudio fails to establish a connection even after manually starting the service (run start-pulseaudio-x11).

    The terminal window displays the following:
    (pavucontrol:7825): Glib-GIO-CRITICAL **:16:58:23.770: g_dbus_proxy_new: assertuib ;/g_IS_DBUS_CONNECTION (connection)' failed

    I uninstalled and reinstalled AlsaMixer and PulseAudio, ran Alsa force-reload, rebooted, and still no sound and no connection to PulseAudio. Now the sound applet is missing in the taskbar as well.

    AlsaMixer states this sound device does not have any controls.

    Are there any suggestions for accessing audio controls to use HDMI audio?

    This post was edited 2019-02-22 14:43:13 -0500
    0
  • What does the command: aplay -l (lowercase L) show?

    If it shows multiple sound outputs, try issuing the command: speaker-test -D hw:0,X -c 2 -r 48000 (where X is 0, 1, 2, etc.)

    If one of the selections produces sound, then add the following lines to the end of /etc/pulse/default.pa
    load-module module-alsa-sink device=hw:0,X (where X is the number from above test that worked)
    set-default-sink output 0

    Next, in the volume control panel set the device profile on the configuration tab to 'Off'.
    Restart/reboot.

    1
  • Thank you for the response.
    The aplay command gives three devices (0,1,and2), all three Intel HDMI/DP LPE Audio.
    The speaker test gives a Playback open error: -16,Device or resource busy for device 0 and an error for the other two (channels count (1) not available for playbacks: invalid argument

    There is no volume control panel

    This post was edited 2019-02-22 16:03:03 -0500
    0
  • Thank you again for your help. After several attempts and reboots, your suggestion worked. Everything is working as it should now.

    2
  • I still get this:

    atomicpi@localhost:~$ start-pulseaudio-x11
    Connection failure: Connection refused
    pa_context_connect() failed: Connection refused

    0
  • Now with a microSD card and the Ubuntu Cosmic LXQT Stand Alone Image, and mine is working as well.

    0
  • Made the changes recommened. Still nothing. .,...

    This post was edited 2019-05-01 16:02:17 -0400
    0
  • The suggestion should work for the 18.04 release, for 18.10 you just need to select the correct output device in the mixer settings.

    In both cases, you will need to select the correct output device in the mixer.

    See my post for more information: https://dlidirect.com/community/champ/forums/1778-atomic-pi-user-forum/topics/6413-how-can-i-choose-the-audio-output-device-in-x-windows

    Also, if your running 18.04, upgrade to 18.10 ASAP as 18.04 is full of buggy issues, one specifically major one being fullscreen video playback in VLC causing a hard reboot.

    my 2 cents.

    Cheers!

    0
  • How do you upgrade to 18.10? I can get it to show up in the Software updater but when I click upgrade it just closes the window.

    0
  • It is not the same situation at each boot!

    Sometime the sound works, and then I can even direct it to an extra USB audio interface of mine
    (a third audio devices)

    But for most boot session, the sound does not work, at least for a long while.
    As is known, when pulseaudio cannot start, it retries every 5 seconds.
    On my Atomic Pi, after some time, and this is not regular, pulseaudio succeeds and start,
    and then I see the two sound interfaces on the Volume Control window (pavucontrol)

    But after booting, I have the same problem with the grey window when going to sound setting
    connection to PulseAudio failed.....
    and to start pulseaudio manually does not work (start-pulsaudio-X11)

    But no sound, at least for a long while! what can be done? I dont find yet a good and fresh explanation on the net

    This post was edited 2020-02-10 08:00:47 -0500
    0
  • As far as LUbuntu 18.04 is concerned, I found information about no good compatibility between the embedded pulseaudio version 11 and the driver for the HDMI sound: snd_hdmi_lpe_audio
    and this is why pulseaudio is not starting!!!
    If the hdmi sound is not used, the hdmi sound card may be blacklisted.
    But you may need it !!!!!
    Then the good suggestion (that we did read on this thread) is to move upward in Lubuntu version, as Lubuntu Cosmic 18.10 and Lubuntu Disco 19.04 have each newer version of pulseaudio ( I checked on the Ubuntu Packages site).
    That is what I am going to try today or tomorrow, hopefully
    and I shall report

    0
  • Hello There! Good News!

    Sorry that I drop quite late on this pulseaudio issue and HDMI sound. I received my first Api very recently.

    Still, the Atomic Pi I received on January 2020 was shipped with a 18.04.1 Bionic Lubuntu.
    So you may receive an SBC with this LTS version. In this LTS version, pulseaudio, the sound server does not work so well with the HDMI sound card, and all the sound delivery may be very unstable.

    Then what you read here is probably relevant.

    You should as soon as possible download from dlidirect
    and install the fresher 19.04 Disco Lubuntu image on your SBC.
    This is because the pulseaudio version which is embedded on the Disco is
    pulseaudio version 12.2
    With this newer version of pulseaudio, every thing works fine.
    This is what I can confirm from my installation, and my tests.

    I did not the 18.10 Cosmic version.

    To upgrade the the LTS Bionic from 18.04.1 to the last LTS subversion18.04.4 do not solve the problem,
    because even the last 18.04.4 has yet the buggy pulseaudio version 11.1.

    The next LTS version , called Focal, is to be delivered as 20.04 in two mont hs.
    It is announced with a pulseaudio version 13.xxx, that should be more than okey.
    Though, I have no idea whether and when we will get an APi dedicated Lubuntu Focal image ready to be downloaded and then dumped on the eMMC.

    And at this moment , I dont know how to build such APi dedicated system image with all the specific APi drivers and configs. Do You?

    Have fun , and more with your wonderful APi!
    Best Regards

    0