Running the Sample Files

Feb 25, 2019 - 11:39 AM

  • Has anyone tried running the sample files that are located on the Desktop? I have been trying to run the script but it keeps erroring out. The error is saying that /dev/i2c-50 is missing but all the documentation states that the GPIO I2C bus is configured to 50 by default so I would think if that needed to be created it would have been done when it was assigned. Am I missing something? Do I need to create the file, or should I reinstall the Adafruit package?

  • I had this same issue on one of my Atomic Pi's right out of the box. I tried another one that I got after the KS campaign was finished (so it could have been from a different batch) and the bno055 Python and JS tests worked fine on that one. I haven't really taken the time to dig in to why /dev/i2c-50 is not being created or what is different between the two, but feel it has something to do with an issue in the i2c-gpio-custom module/service unit. I'll report back if I get a chance to look into it though.

  • I attempted to create the file myself, however, I then got an inappropriate ioctl for device error for the assert line.

    I do find it interested that the post-KS model works fine. I wonder if they changed something in the 'production' models from the KS models, or if it is one of those hit and miss things where some work and some don't.

  • I've got another one from the KS campaign that I don't think I've tried the bno055 example on yet. I'll get it out this evening and see if it will run it as-is and then compare it to one of the boards I got after KS and see. I'll post back this evening with results.

  • FInally got a chance to test the bno055 sample on the 2nd of my two KS boards and it does not run on that one either. Same issue that you see in that the i2c-gpio-common kernel module is not loading at boot and, therefore, the /dev/i2c50 inode is not being created.

    As to other obvious differences between the KS boards I have and the ones I just recently received other than the samples work fine on the newer boards:

    -The default password is now displayed on the graphical login to the left of where it is to be entered so no more switching to the TTY to see it.

    -It appears the ext4 partition on the eMMC is now being extended to use all available space (at least my new ones were).

    I've not really dug-in much further looking for any other differences, but I did go through the process of taking a fresh install of Lubuntu 18.04 LTS and then going through the steps of getting all of the files copied over and the DKMS i2c-gpio-common module installed and the service for it re-created so that all the samples run properly. As soon as I get all my notes straight and test it again I'll post the process here. The quick fix is to use the images that the DLI team have made available, but I think there are quite a few people that have invested a lot of time in getting a fresh install loaded and set-up just how they want it so a doc on getting the samples working, etc... for those folks would be useful. It's not a particularly complicated process as long as you have the original files saved off somewhere. I'll be creating a tarball of them though in case anyone needs them.

  • Yeah, I just got it working by installing their 18.10 image.

    Thanks for the help.