Mar 2, 2019 - 8:30 PM

  • It might take me a few days to find the time to get an install of Lubuntu 18.04.1 with kernel 4.18.0-16 up and going to test this for you. That would at least get me in the ballpark of approximating your install. You could try installing the libelf-dev package that the error in the make.log is stating is missing and could be causing this issue.

    The line in the make.log I'm referring to is:
    Makefile:970: Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel

    so try: sudo apt-get install libelf-dev (that should be the one that is relevant to your Lubuntu install).

    Not knowing the state of your install (what iso/installer you used, what options you selected when installing, etc...) makes this a bit trickier to troubleshoot, but I'm sure we can figure it out.

  • I am sorry I did not document the installation or steps. I was frustrated at that point after trying all of the images repeatedly to no avail.

    I installed the libelf-dev package and it still bombs. The make.log file is the same with the exception of the libelf error being gone now.

    I went ahead and followed the remaining steps, ignoring the errors, and rebooted.

    The works and the gpio-test programs do not.

    At least it is progress.

    Thank you again for your time and help.

    This post was edited Mar 18, 2019 09:12AM
  • Hi, please don't spend time on this issue for now. The APi is booting then going to a blank purple screen and will not respond to anything now. I can boot in safe mode but it will not boot normally without going to the blank screen. The only changes I made were adding an antenna to the Bluetooth connector, connecting a Bluetooth mouse and keyboard, and the changes for the gpio and bno055 sensor (steps listed in the text document). I may have to start from scratch again. Thank you again for your time.

  • Sorry to hear that Rebecca. Let me know if you run into any issues when you re-install (if you end-up having to do so, that is). You might try booting an Lubuntu install image from USB and selecting the option to 'try' Lubuntu rather than install and, from there, run a filesystem check on your eMMC (or SD card if that's were you're installation is located). One of mine had a similar issue out of the box and I was able to get it booting again after running fsck against it a couple of times until the filesystem check finally came back clean.

  • I tried booting from one of the four usb stick ISO and image files I created during this process so I could run fsck. fsck won't run (boot2? is mounted?).

    After booting from the stick, I went through each option for fixing software, grub, etc. but none really worked.

    I was able to finally get it to boot normally after disconnecting the break out board.

    It is starting to look like memory issues. I tried starting NetBeans 8.2 and it went back to a blank screen and locked up. At this point, I am at a loss as what to try next.

  • Hi radu7,

    At this point, I think the APi itself is the issue. I have tried removing the breakout board, the USB hub, running in recovery mode, running the OS from a USB (image from download center, Ubuntu 18.04, Ubuntu 18.10), and last, I tried to reinstall the operating system, telling it to erase the drive and install the new operating system.

    The screen goes blank after accessing programs or basically anything.

    During the reinstall, it went to the point of beginning the install (after answering the questions about language, location, erase drive) and once the install began, the screen went to a blank purple display and hung. The same as it did during all other attempts to do or fix anything.

    This APi will likely go into a parts bin to use spare parts for something else.

    Again, I appreciate your time and efforts.

  • That's a bummer for sure. Sorry to hear that. You might give DLI a call or send their support team an e-mail. Their support is great and they may be willing to swap that one out for you.

  • Hello Rebecca, by 'struct spi_gpio_platform_data’ has no member named ‘sck'' I guess you aren't using the latest driver, which is at and should also be included in latest images downloadable at . It supports kernels 4.17+ since .

  • Hi Sergey,

    That would probably be the issue here and thank you for pointing this out. The drivers/files that I provided in the links in this thread that Rebecca was using were ones taken from an image that came with one of the initial Kickstarter boards and not the latest images. I had not personally tested them with kernels past 4.15

    Thank you for the links to the latest driver as well!