Help, not powering up

May 11, 2019 - 4:59 PM

  • Hello,
    I've used a few RPI's, but this is my first Atomic Pi, that being said, this thing will not boot. Baby breakout board is used for power, with a 5v 5a brick. Amber/yellowish light on board comes on when I power it, however keyboard never lights up, NIC never turns on, and screen never comes up. I have tried a 5V3A brick, a 5V5A brick, this thing just does not seem to want to turn on. Any assistance is welcome. Thank you.

    0
  • Did you find a solution to this?

    I'm using a 5v 3.5a supply, two pins to both rails and my board is doing the same - briefly powers on and switches to the HDMI channel then nothing. No NIC lights, HDMI signal dies with no signal (have tried different screen and lead)..

    I have 5V on the webcam socket, so I'm pretty sure my headerboard is powering the 5V in the right place: https://ibb.co/R79X4KX (image)

    Any tips most welcome. Thanks :)

    This post was edited 2019-06-26 12:41:31 -0400
    0
  • What gauge wire are you using?

    It's not just the volts, it's also how much current your cables will pass/supply. 5.2V with insufficient amps will cause the symptoms you describe.

    I'm successfully using a 5V3A supply with a USB 2TB HDD, a 5" HDMI, but using 4 +ve and 4-ve pins.

    If your wire is typical Dupont 24/26AWG, increase the number of pins, or change the wire gauge.

    This post was edited 2019-06-26 14:14:20 -0400
    1
  • I've got this running now thanks :)

    It was a PSU issue, so I'm guessing that the declared 3.5A wasn't entirely truthful. I soldered up a molex connector and rigged up from an ATX PSU with a good 5V rail and it powered up fine with the same gauge wires to the APi.

    0