USB 3 not working

May 27, 2019 - 10:38 AM

  • I have been getting into a number of things with the Atomic Pi but have never been able to get the usb 3 port to work. At first I had my keyboard and mouse plugged in and never could get them to work. eventually I plugged them into the usb 2 on the breakout board and they worked fine. I then suspected something was amiss with the OS load since it was acting a little flaky. I finally got the Cosmic image loaded and thought that might solve the issue. But still no USB 3. A little more troubleshooting and there is no 5 v on the port.

    Has anyone else had this problem? Wondering is there a jumper some where is it a bad board? I ordered another board from Amazon to have on hand. These came direct from DL so no one else has touched them.

    Any thoughts?

  • But you say USB 2 works. Hmm... the prints seem to me to indicate that the 5V for both comes from the same source. Any chance the connections are just dirty? I saw somewhere else where someone said their Net connection didn't work until it had been plugged and unplugged a few times.

  • I read that also and saw it on the schematic. I also tried a powered usb hub and still no connection. Everything else seems to work. I looked at the connector solder points with a magnifier and everything looks good. I guess it could one of the traces in the multi-layer board.
    I may call and see what DL says on the subject.