Do I have a defective board?

May 30, 2019 - 4:13 AM

  • Hi all,
    Bought the Atomic Pi board as on a paper it looked extremely promising... Actually, wanted to buy few of them, but decided to try it first. Well, a lot of pain. The preloaded image would not boot at all (it would start, but stuck on a blinking cursor) Tried different ubuntu/lubuntu distributions. Managed to boot Lubuntu 18.10 from USB, but it is useless - if I try to update the packages it crashes during the process. Sometimes it just crashes without any visible reason - the screen goes pink, yellow, etc. It is not a power problem - I'm using 10A power supply, put 4 wires on GND and VCC, added some capacitors to filter out any bad things. I also tried to re-flash the image they have on a website with dd command - it results in immediate crash (white scree). Seems like a huge waste of time. What can I do with this board? Am I the only one that desperate?

    This post was edited May 30, 2019 04:24AM
  • I used all the power & gnd connections and haven't had an issue. There is probably a good reason why there are so many connections for power.....I know how many the User guide says you can get away with.
    If the psu you are using is a switchmode supply I'd remove the extra caps, it maybe an idea to monitor the voltage and/or current whilst in use, it might have regulation problems.
    From memory the psu I'm using is a 4amp switchmode with a unloaded voltage of 5.2 ish volts.
    Lubuntu 18.04 (Bionic) works, even with a realtime kernel.

  • Thanks Robert,
    Yep, the power is super important for this baby...
    I built the connector (!AgXQnBFeIFXXwjQ1OFa8aCsVPOg0) from 2.54 Male pin headers (4+4 wires) and added 1000mF and 100pF capacitors that can only help.
    Still waiting for the 5V psu to arrive. In a meantime, I'm using a 10A lab power supply, setting it at 5.2V to compensate for the voltage drop. From my observations it never consumes more than 1.6A. I'm at 4.85 - 4.9V on the connector at max load, but afraid to set more than 5.2V - as at lower load it can go higher (on the board) and I don't want to fry it (need shorter cables)... At the beginning I used 2 pairs of dupont cables and it was not good enough. Anyhow, the situation is more stable now. I don't want to try apt-get upgrade anymore, it failed 2 or 3 times corrupting the things, but I was able to update using Lubuntu GUI tool. So, it seems to work now (sometimes the screen blinks, but that is less important to me, I need it headless), and when it works it does everything I need even better than expected. So, lets wait for the PSU to make a final verdict :-)
    ...Still, I cannot explain why it didn't boot from the preloaded image - I was able to boot from USB, and with an external flash it draws more power, so the voltage was even lower...

  • First boot took forever on mine but it eventually posted. I'm only using a 3a supply the originally ran a Vizio costar. I flashed lubantu 19.04 to both my api which makes audio work properly from the get go. I did however use a 26pin header and breadboard barrel jack soldered to a pcb as a diy small adapter board.