I've ordered 4 boards now, these things are fantastic! However, I'm seeing one strange issue on two of my boards. 3 of my boards are using the baby breakout mini boards for power, and the other is using the larger breakout board.

All seem to be working except for two of the mini breakout boards. When plugged in, the pi is able to boot up, but as soon as I begin to do any tasks on the system (even as simple as opening a terminal), the NIC turns off, then the system freezes up.

I thought this could be a power issue at first, so I swapped out my 3A 5v wall adapter for an actual beefy PC Power supply (using the 5v line). Still, this issue persists. I haven't tried bypassing the mini breakout board yet, but it appears this issue only impacts two out of my 3 boards, so my first guess was an issue with the mini breakout boards themselves.

Has anyone seen something similar? If it means anything, I was able to snag the dmesg error before the system crashes (right when the NIC goes down):

rtl_counters_cond == 1 (loop: 1000, delay: 10)

Looking forward to a solution. Thanks for reading!

Edit: Forgot to mention, I've tried booting into the following OSes, and all show the same issue:

  • Debian
  • Ubuntu
  • Linux Mint
  • xubuntu