Impossible to start OS with emmc

Jun 16, 2019 - 10:29 AM

  • Hello,

    I am currently doing tests with with Atomic Pi to make an emulation box. Recalbox runs quite well, and Retropie over Ubuntu 18.10 (official image provided for the Atomic Pi) also. These 2 OS boot and run well on SD card or USB.

    While trying to use emmc, they don't start. In both case, flashing with DD worked without error message at 25 MB/s until the end. While booting, I can reach the Grub Ubuntu menu in the first case, or Recalbox menu for the second test.

    After the boot menu :

    • Ubuntu shows a black screen with a little cursor at the top left of the screen
    • Recalbox in verbose mode starts to run kernel and services correctly, but cannot mount the file system.

    An Idea ?
    Is it possible to test the the EMMC memory ?

    Thanks.

    0
  • As an up, Has anyone sucessfully installed linux on the on-board emmc ? If Yes, with the command line dd if=mylocation/myimage.img of=/dev/mmcblk0 bs=1024k oflag=dsync status=progress ? (with the right location...)

    0
  • That will only work if the image you're copying is a previously installed and configured AtomicPi image, such as those downloadable from the DLI website.

    All other Linux images should be booted from a USB drive or SD card as a live system, and then installed using the appropriate installer.

    0
  • Thank you for the answer.
    In my case, I cannot also boot on emmc with the Ubuntu image downloaded from the DLI website (Atomic Pi Ubuntu (Cosmic 18.10) LXQT Image (camera ready))

    I'll try with the 19.04...

    This post was edited 2019-06-28 15:57:25 -0400
    0
  • Now working with the 19.04 image ! Solved.

    0